npm install update angular cli to next

1.) > npm install @angular/cli@next

> uws@9.14.0 install C:\~~~\node_modules\uws
> node-gyp rebuild > build_log.txt 2>&1 || exit 0

> @angular/cli@6.0.0-rc.5 postinstall C:\~~~\node_modules\@angular\cli
> node ./bin/ng-update-message.js

================================================================================
The Angular CLI configuration format has been changed, and your existing configuration can
be updated automatically by running the following command:

ng update @angular/cli --migrate-only --from=1
================================================================================

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

+ @angular/cli@6.0.0-rc.5
added 206 packages from 137 contributors, removed 492 packages and updated 858 packages in 815.845s

=====

Used this instead!

2.) > ng update @angular/cli --migrate-only --from=1.7.0


What you might see:

Updating karma configuration
Updating configuration
Removing old config file (.angular-cli.json)
Writing config file (angular.json)
[ .................] / fetchMetadata: sill pacote range manifest for find-cache-dir@^1.0.0 fetched in 764ms