angular cli upgrade

Unable to find "@angular/cli" in devDependencies.

Please take the following steps to avoid issues:
"npm install --save-dev @angular/cli@latest"

_ _ ____ _ ___
/ \ _ __ __ _ _ _| | __ _ _ __ / ___| | |_ _|
/ △ \ | '_ \ / _` | | | | |/ _` | '__| | | | | | |
/ ___ \| | | | (_| | |_| | | (_| | | | |___| |___ | |
/_/ \_\_| |_|\__, |\__,_|_|\__,_|_| \____|_____|___|
|___/

Angular CLI: 1.7.1
Node: 9.11.1
OS: win32 x64
Angular: 5.2.10
... common, compiler, core, forms, http, platform-browser
... platform-browser-dynamic, router, upgrade

typescript: 2.8.3
webpack: error


Used:

npm cache verify

Using:

npm install -g @angular/cli@next

And:

"npm install --save-dev @angular/cli@latest"


> node ./bin/ng-update-message.js

================================================================================
The Angular CLI configuration format has been changed, and your existing configuration can
be updated automatically by running the following command:

ng update @angular/cli –migrate-only –from=1
================================================================================

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.2 (node_modules\@angular\cli\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.2: wanted {“os”:”darwin”,”arch”:”any”} (current: {“os”:”win32″,”arch”:”x64″})

+ @angular/cli@6.0.0-rc.5
added 4 packages from 3 contributors, removed 825 packages and updated 17 packages in 216.43s